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Handle Tool  

CNRI developed a simple GUI tool for performing handle operations such as creating and deleting handles, 

authenticating, and setting up a handle server. The Handle Tool has been found to be useful for quickly 

creating and updating handle URL values that are used with the World Wide Web. 

The Handle Tool is included in the HANDLE.NET software distribution. 

Before using this tool it is important that you read  "How Your Prefix is Set Up" in the Handle Technical 

Manual  (http://www.handle.net/tech_manual/HandleTechnicalManual.pdf).  

The Handle Tool runs on Windows, Linux and Mac OS X, and requires that Java™ 1.5 be installed. The tool 

uses Java™ WebStart, which is built-in on OS X, and comes with Java™ 1.5 for Windows and Linux. 

1. Start the Handle Tool 

The Handle Tool is initiated by navigating to the folder containing the directory "bin" and configuration file 

(in previous examples "srv_1"). Running the following script will start the handle tool:  

bin/hdl-admintool 

On Windows: bin\hdl-admintool.bat 

 

2. Default Window 

The application's Default Window, displayed at launch, is a panel used to look up an existing handle's values;  

to create, modify or delete handles;  and to authenticate an administrator. 

Figure 1: Default Window 

Default Window Options 

Under the File menu in the default window there are three options  (see Figure 2). 

http://www.handle.net/tech_manual/HandleTechnicalManual.pdf
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Figure 2: The File Menu 

(1) Open Batch File. Open an exiting batch file stored on the desktop, prepared according to the 

specification and ready for upload. The pathname of the file will be added to the Batch Process Tool. 

(See also Section 10, "Batch Processing".)  

(2) Clear Cached Handles.  Empty the cache of data stored from previous handle resolutions. Like most 

name resolution systems, the Handle System makes use of caching (storing the values it retrieves 

from the Handle System) in order to improve performance and keep network traffic and server load 

to a minimum. The default configuration for the Handle Tool is to cache all handles as they are 

resolved, and to use the cached values whenever possible. This allows the tool to display the 

resolved values of most handles with little or no delay. However, if you know that a handle has been 

modified, but the change is not reflected in the View Handle display, click Clear Cached Handles. The 

next time that handle, or any handle, is resolved, it will be retrieved from the handle server rather 

than the local cache. The cache is automatically cleared each time you quit the Handle Tool. 

(See also "Add... Button" for more information on caching, TTL, and TTL Type.) 

(3) Authenticate.  Authenticate as an administrator using Public/Private Key pair or a Password (Secret 

Key). See also" Authentication". 

Quit the Handle Tool by closing the Handle Tool window. 

Under the Tools menu in the default window there are several options (see Figure 3): 

(1) Batch Processor. Uploads handle records contained in a batch file.  

(2) Console. Displays the communication between the computer you are on and the handle servers. 

(3) Home/Unhome Prefix. Tells servers in a site that they are (or no longer are) responsible for resolving 

handles with a given prefix. (See Homing/Unhoming a Prefix.) 

(4) Checkpoint a Handle Server. Makes a back up of the supplied handle server. 

(5) List Handles. Lists all the handles associated with a supplied handle. 
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Figure 3: The Tools Menu 

3. Console 

The console records the interaction between the Handle Tool and the handle servers it contacts. 

Using the Console Window 

The Console window can be opened at the time the Handle Tool is launched, and moved to the side of the 

desktop (see Figure 4). Use the Console to view the communication between the computer you are using and 

the Handle System. You will also see general diagnostic and log messages displayed in the console. 

Figure 4: Console 

The Console displays all client requests sent to the server (including the IP address of the server) and all 

responses received from the server, and will maintain the list until the Handle Tool is quit. The contents of 

the window can be cleared at any time by clicking the Clear button, or saved to a desktop file for analysis by 

clicking the Save button. Error messages should be saved for troubleshooting. Dismiss closes the window. 
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4. Authentication 

You must have an administrative handle to use for authentication in order to administer handles. When 

authenticating yourself you will be providing the following information: 

(1) Your admin handle (which is usually your prefix handle) and the index of your public key value within 

that handle; or, some organizations use individual handles with passwords. 

(2) Your private key. Note: your private and secret key will *never* be sent over the Internet by the 

Handle System. You only need to provide this to the Handle System client software so that it can 

prove to any handle server that you have this information.  

The owner of a prefix under which you are administering handles (the part of the handle before the slash) 

will have given you permission to create handles under that prefix by adding your administrator handle, and 

the index for your key value, to a list of administrators who have permission to create handles under that 

prefix.  

When you send a "create handle" request to the Handle System, the server will verify that you are the 

individual identified by the administrator handle (i.e., your private key matches your public key, or you enter 

the correct password (secret key)) before the requested handle is created. 

Administrator Authentication 

Select Authenticate from the File menu, or click Authenticate on the Default Window to display the Handle 

Authentication Window (see Figure 5 below). 

Figure 5: Handle Authentication Window Showing Public/Private Key Authentication 

Enter your administrator handle into Your ID:. The default index value is 300.  (Change this value only if 

required by your system administrator.) 

Select the Key Type:, either Public/Private Key as illustrated above, or Password (Secret Key). Your Key: will 

display the name of your Key file.  If you are using the tool for the first time, or your private key file has 

moved or changed, click Select Key File to browse for the (updated) file.  



Handle Tool 

7 

 

Click OK.  If you use Public/Private Key, you will next be asked to enter your passphrase (see Figure 6). 

Figure 6: Enter Passphrase 

If you selected Password, the Handle Authentication window will allow you to enter your password (see 

Figure 7). 

Figure 7: Handle Authentication Window Showing Password (Secret Key) Authentication 

When authentication is successful, your administrator handle will display in place of the Authenticate button 

on the default window (see Figure 8). 
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Figure 8: Authentication Complete 

5. Lookup 

It is not necessary to authenticate yourself as a handle administrator before viewing a handle record. Some 

low level system handle values remain hidden from view, but values that have public read permission and 

might need to be edited by an administrator will be displayed in this view. 

Lookup a Handle Value 

Enter the handle into the Default Window's textbox, and click Lookup. The publicly readable values stored in 

the handle will be displayed in the View Handle window (see Figure 9 below). 

Figure 9: View Handle Window 

Edit Handle 

To edit one or more of the values for the handle displayed in the View Handle window, click Edit Handle to 

bring up the Edit Handle Window. (See the section Modify for instructions for Modifying a handle using the 

Edit Handle window.) 
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Copy Values 

The Copy Values function is a short cut for creating handles with the same values as an existing handle. 

To create a new handle that will have all (or most) of the same values as the handle being displayed in the 

View Handle window, click Copy Values. Type the new handle string into the window, and the new handle 

will be created with all of the copied values.  The new handle values will be displayed in a Create Handle 

window, which includes a button for removing any unwanted values. 

Figure 10: Copy Values to New Handle 

6.  Create, Modify or Delete Handles 

Handles can be created, modified or deleted individually or in batches. This section explains how to create, 

modify or delete handles one at a time. See Section 10, Batch Processing for information on creating and 

processing batches. 

If you do not authenticate yourself before attempting a create/modify/delete, the Handle Authentication 

window will appear as the first step.  (See Section 4, Authentication, for instructions.) You must have 

permission to perform the requested action on any given handle. 

Create New Handle 

To create a new handle, use the Create button on the Default Window. Handles may have any number of 

associated values. By default, the Handle Tool will assign an administration value to the new handle. See 

Value Types for an explanation of the types of values that can be included. 

If you are creating a handle that contains the same (or most of the same) values as an exiting handle, do a 

Lookup for the existing handle and click Copy Values on the View Handle window (see the section  Copy 

Values). 

Administration Values 

Every handle must have at least one "administration value" associated with it, to identify the administrators 

that have permission to act on that handle, and which permissions each administrator will have. 

Administration (or admin) values are values of type HS_ADMIN, and for consistency are being given an index 
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of 100. (If there are multiple admin values, then the additional indexes are 101, 102, 103, and so on.) 

HS_ADMIN values specify who can perform administration by referring to values stored in other handles. 

Create Handle Steps 

To create a handle, first enter the new handle string into the text box on the Default Window, and then click 

Create.  

The Create button offers three options (see Figure 11 below).  

(1) Selecting Create Simple URL Handle will display a panel for quick entry of a handle's URL value, and then 

display that value in the Create Handle window.  

(2) Create Simple Email Handle will display a panel in which to enter an email address, and then display that 

value in the  Create Handle window.  

(3) Create Blank Handle will bring up the default Create Handle window (see Figure 11  below). 

Figure 11: Create Button Options 
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Figure 12: Create Handle Window 

The new handle will automatically have a default HS_ADMIN value that, depending on the configuration of 

your naming authorities, will most likely be sufficient. Additional HS_ADMIN values can be added. 

Add... Button 

To add additional values to the handle record, click Add.  

 

Figure 13: Add... Button Options 

Selecting one of the Add button options affects the Value Type displayed in the Add Value window.  Selecting 

URL, Email or Administrator will fill in the appropriate Value Type in the Add Value widow.  Add Blank Value 

requires the administrator to identify the type for the new value. 

Note: If you have selected Create Simple URL Handle and entered a URL into the text box, you need only 

click Create Handle to complete the process and create the handle. You will not need to add additional 

values as explained in the remainder of this section. When the handle has been created, a message as shown 

in Figure 14 will display. 
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Figure 14: Add Handle Value 

For example, selecting Add URL Value will fill in the Value Type with URL. (Selecting Add Blank Value will 

leave the Value Type blank so that the appropriate type can be selected from the pick list under the down 

arrow, shown in Figure 14 above.)  The URL is added in the text window, in place of the example URL shown. 

Clicking Show Details will display additional data about the new value being added (see Figure 15). It is only 

necessary to use Show Details when changes to the default settings are required. The default set of 

permissions is the recommended practice for most handles. ("Writable by Everyone" permission is not 

recommended.)  Should it be necessary to change the Index value or TTL (Time To Live) values that affect 

caching, use this window to change the settings. 

TTL stands for "Time to Live" which indicates that maximum number of seconds a handle value can be cached 

before a handle client must clear the value and retrieve it again from the Handle System. Setting the TTL to a 

low value forces handle clients to retrieve the handle more often, so low values are more appropriate for 

handles that change frequently. 

The TTL Type provides a choice between "relative" and "absolute". If the TTL Type is "relative" then the TTL 

value will indicate the number of seconds since being retrieved that the handle value is valid. If the TTL Type 

is "absolute" then the TTL value indicates the number of seconds after Jan 1st, 1970 12:00 am GMT that the 

handle value is valid. The absolute TTL Type is useful for handle values that expire or will be updated at a 

specific date and time. 

The default TTL Type is "relative" and the default TTL is 86400 which means that the handle value can be 

cached for only 24 hours before it being re-retrieved. There are very few situations in which the default 

settings are not appropriate. 
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Figure 15: Show Details Window for "Add Handle Value" 

In addition to the settings shown in Figure 15, the Show Details window for an Administrator Value will 

display all of the administrator permissions possible for that admin value (see Figure 16). These should be 

edited with care and only when necessary. 
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Figure 16: Add Admin Value 

Value Types 

In addition to URL, EMAIL, and HS_ADMIN, there are additional Value Types. They include:   

HS_ALIAS – used to add a handle alias as a handle value.  

HS_SITE – used to add the site information for prefix handles to indicate where handles with that 

prefix are resolved.  

HS_VLIST  – used to define administrator groups with a list of other handle values.  

HS_SECKEY – used to add a secret key as a handle value. Typically, the 'public read permission' for 

this type of value would be turned off.  

HS_PUBKEY  – used to add a public key as a handle value.   

HS_SERV – used to add site information as a handle value.   

URN – used to store a value identified as a URN (type not defined or registered).   

INET_HOST – used to identify a handle value which has an IP address or host name. 
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DESC – UTF8-encoded text descriptions of the object identified by the handle.  

Additional information on Value Types can be found in the Handle System Informational RFCs. 

Additional Options for Managing New Handle Values 

A value can be changed after it has been added by clicking on it to select it, and then clicking the Edit button. 

Values can be removed before the handle is created by selecting them and clicking Remove.  A warning 

message will display to verify that removing the value is the action you intended. 

Create Handle 

When all values have been added and are correct, click Create Handle. If the creation is successful, the 

message displayed below in Figure 17 will display.  If there was an error that prevented the handle from 

being created, the message will display the error instead. 

Figure 17: Successful Creation Message 

7. Modify 

To modify a handle means to change one or more of its values, or remove values. (A handle string itself 

cannot be "modified". If you create handle 123/456 when you meant to create 123/457, you must delete 

123/456 and create 123/457.) The terms "modify" and "edit" are frequently used interchangeably.    

In the Default Window text box, type the handle you wish to modify, and click Modify.  If you have not 

authenticated yourself, the Handle Authentication window will display. 

Modify a Handle By Changing Its Values 

The Edit Handle window displays all the existing values that you have permission to edit. To change a value, 

click on the value to highlight it, and click Edit, or highlight the value and double click.  

http://www.handle.net/documentation.html
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Figure 18: Edit Handle 

The Edit Handle Value window displays the current data with details hidden. The Index value will be grayed 

out. It cannot be changed. If the Permissions or the TTL value must be changed, click Show Detail. Enter the 

change and click Done.  

Figure 19: Edit Handle Value for Email 

The Edit Handle window may also be retrieved following a LookUp by clicking on the Edit Handle button in 

the View Handle window.  
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8. Remove Handle Value 

To delete a selected value from a handle (not a handle itself) select and highlight the unwanted value and 

click the Remove button in the Edit Handle window. A Delete Confirmation message will appear to confirm 

your choice before the handle value is removed. (see Figure 20 below). 

Figure 20: Remove Handle Value Confirmation 

9. Delete Handle 

To delete a handle means to remove it permanently from the Handle System. Enter the handle to be deleted 

into the Default Window, and click Delete.  If you have not authenticated yourself, the Handle Authentication 

window will display. A confirmation message will display to verify that deleting the handle is the action you 

intended. The action cannot be undone. 

Figure 21: Delete Handle Confirmation 

10. Batch Processing 

Handles can be created, modified or deleted in "batches".  Batches can be submitted via the Handle Tool, or 

by using the command line utility described in the Batch Operation section of the Handle Technical Manual 

(http://www.handle.net/tech_manual/Handle_Technical_Manual.pdf).  
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All batch files are plain text format lists of create, modify or delete operations for specified handles. One 

batch file can have more than one type of handle operation.  (See the Handle Technical Manual chapter on  

Batch Operations referenced above for a list of operations, formats, examples, and instructions for creating 

batch files.)   

The Batch Processor tool in the Handle Tool submits batches to the Handle System, provides output for 

review including actions taken during the process, and reports success or errors encountered during the 

process. 

You can watch the batch upload process by selecting Open Batch File from the File Menu on the Default 

Window.  

 

Figure 22: Open Batch File Option 

An Open Batch File window will display with which you can browse the desktop to find the batch file. The 

Batch Processor will start, and the path to the selected file will display in the Batch Processor window.  

Figure 23: Batch Processor With Single Batch File Added 
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The Batch Processor can also be started by selecting Batch Processor under the Tools menu on the Default 

Window.  

 

Figure 24: Starting the Batch Processor 

Use the Add button to add more batches to the operation, or highlight a batch file name and select Remove 

to delete a previously selected batch file. The output (log) from the batch process can be directed to display 

in the Batch Processor window (See Figure 25) or directed to a file. If Send Output To: is changed to a file, use 

the Choose File button to bring up the Select Output File window for choosing a file for the output. See 

Figure 25 below.  

Figure 25: Send Output To a File 

Click on Run Batch(es) when all batches have been listed. If you have not authenticated yourself to the 

Handle System, the Handle Authentication window will display before the process begins. However, if 

authentication is specified in the batch file, then that is used instead. A message will display when the 

processing is complete.  

 

 

 



Handle Tool 

20 

 

 

 

 

 

 

 

Figure 26: Processing Complete Message 

The Output from a batch process shows the handle operations that were processed, any errors that 

occurred, and the summary of each batch (number of items, number of lines in the file, number of successful 

items, and processing time). 

The output displayed in Figure 27 indicates that the batch failed to process, and provides diagnostics 

explaining what caused the failure. Success/Total Entries would be 1/1 if the batch had processed 

successfully. The batch should be edited and resubmitted. There would be output for each batch if more than 

one is submitted.  

Figure 27: Batch Processor with Output Displayed 
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11  Homing/Unhoming a Prefix 

"Homing" a prefix on a particular site tells the server(s) that make up the site that they are responsible for 

the given prefix. When a resolver asks for a handle under that prefix, the server can say "Here it is." or "It 

doesn't exist." or " I don't have it." Permission to Home and Unhome is in the server admins parameter in the 

config.dct file in the server directory.   

From the Tools menu, click on the Home/Unhome Prefix. See Figure 28 below.  

 

 

 

 

Figure 28 Home/Unhome Prefix Tool Menu 

Enter the prefix to be Homed or Unhomed, and select either "Home Prefix" or "Unhome Prefix".  The site 

information can be provided either by selecting a siteinfo.bin file (default), or by selecting "By Address" and 

providing the Server Address and Server port number. See Figure 29. 
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Figure 29 - Home detail 

 

 

 

 

 

 

 


